1. 首页
  2. three.js

three.js模块导入/使用

到旧版本。n我必须修改该文件。n但也许我还没有找到最聪明的方法,在不访问外部网站或完全接管修订版的情况下,尽可能少地进行修改?n但它正在工作。霍夫.de 2n宁静是合适的。n如果这能奏效,那就太好了!谢谢您。当我知道我需要什么模块时,我最终会这样做。目前,我使用示例中的模块。我试过nodejs,但它是一团糟!安装大约需要20分钟,然后在npm上安装pathtomyproject三:否package.json找到…没有帮助,没有文档,什么都没有。永远不再使用。n顺便说一句:新年快乐!nhofk:n我在过去几年中经历了这些阶段n祝您的第51年既繁荣又安宁,老师。n模块是静态相互依赖的n我不认为这里是这样的。示例依赖于function clickHandler(event) = \”_blank\”;link.click();}saveLink.addEventListener(\”click\”, clickHandler);,但link.target不依赖于任何示例。要使代码静态地相互依赖,必须有两个相互导入的文件(至少我是这么理解的)。n需要识别一个文件夹“build”。我一点都没有。n啊,是的,现在我明白你的问题了。这对我们来说是一个很难解决的问题three.js一边。这在Github上讨论过几次,除了告诉用户保持与repo中相同的文件夹结构外,我不确定是否有其他解决方案:n- 供应商三个构建3.module.js示例jsm控件Orbitcontrols.js然后在您的代码:link.target如果你这样做,那么模块就会工作。looee:要使代码静态地相互依赖,你必须有两个相互导入的文件(至少这是我的理解)。我指的是单向依赖。你知道我的英语不好,我也不知道技术术语完全是用英语。对于技术语言中应该精确的东西,译者并不总是很有帮助。我仔细查看了结构。导入几乎都很简单。只是一些更复杂的导入。2020-01-03_12.42.29722×129 5.28 KB因为在收集的基本示例中,只有几个模块被反复使用,如果我将它们复制到一个目录中并调整导入路径,会更容易、更清晰。尤其是使用这些示例的初学者,如果发现嵌套目录,会遇到更多问题。尤其是对我来说,这会让我付出更多的努力。我将在适当的地方指出确切的结构供应商等。我将给出一个更改示例。我注意到只有少数模块可用作.min,甚至没有3.module.js.这有什么原因吗顺便问一下,我在评论中发现了一些丢失的链接。Athree.js专业人士可以肯定地解决这个问题。断开(或更改)的链接AsciiEffect.jshttp://lab4games.net/zz85/blog2http://www.nihilogic.dk/labs/jsascii/dat.gui.module.jshttp://code.google.com/p/dat-gui1现在GitHub-dataarts/dat.gui: dat.gui是一个用于JavaScript。subsectionModifier.jshttp://www.lab4games.net/zz85/blog2https://www.centerionware.com/1服务器错误500CondNode.jshttp://www.lab4games.net/zz85/blog2hofk:我注意到只有少数模块可用作.min,甚至3.module.js这有什么原因吗我认为这里的理由是,用户应该使用捆绑程序并缩小他们的代码用于生产。我不确定,现在我们正在切换到http/2,并被告知要将内容分成100kb的块n- 三个构建3.module.js示例jsm控件Orbitcontrols.js然后在您的代码:link.target如果你这样做,那么模块就会工作。looee:要使代码静态地相互依赖,你必须有两个相互导入的文件(至少这是我的理解)。我指的是单向依赖。你知道我的英语不好,我也不知道技术术语完全是用英语。对于技术语言中应该精确的东西,译者并不总是很有帮助。我仔细查看了结构。导入几乎都很简单。只是一些更复杂的导入。2020-01-03_12.42.29722×129 5.28 KB因为在收集的基本示例中,只有几个模块被反复使用,如果我将它们复制到一个目录中并调整导入路径,会更容易、更清晰。尤其是使用这些示例的初学者,如果发现嵌套目录,会遇到更多问题。尤其是对我来说,这会让我付出更多的努力。我将在适当的地方指出确切的结构供应商等。我将给出一个更改示例。我注意到只有少数模块可用作.min,甚至没有3.module.js.这有什么原因吗顺便问一下,我在评论中发现了一些丢失的链接。Athree.js专业人士可以肯定地解决这个问题。断开(或更改)的链接AsciiEffect.jshttp://lab4games.net/zz85/blog2http://www.nihilogic.dk/labs/jsascii/dat.gui.module.jshttp://code.google.com/p/dat-gui1现在GitHub-dataarts/dat.gui: dat.gui是一个用于JavaScript。subsectionModifier.jshttp://www.lab4games.net/zz85/blog2https://www.centerionware.com/1服务器错误500CondNode.jshttp://www.lab4games.net/zz85/blog2hofk:我注意到只有少数模块可用作.min,甚至3.module.js这有什么原因吗我认为这里的理由是,用户应该使用捆绑程序并缩小他们的代码用于生产。我不确定,现在我们正在切换到http/2,并被告知要将内容分成100kb的块n- 构建3.module.js示例jsm控件Orbitcontrols.jsn- 3.module.jsn- 示例jsm控件Orbitcontrols.jsn- 示例jsm控件Orbitcontrols.jsn- jsm控件Orbitcontrols.jsn- 控件Orbitcontrols.jsn- Orbitcontrols.jsn Module Import / Usagen

three.js模块导入/使用 为WP2原创文章,链接:https://www.wp2.cn/three-js/three-js%e6%a8%a1%e5%9d%97%e5%af%bc%e5%85%a5-%e4%bd%bf%e7%94%a8/