1. 首页
  2. three.js

three.js更新r112后出现Typescript错误

更新后three.js对于r112,我得到了以下错误:n节点\\模块/three/src/core/BufferAttribute.d.ts(21,6)中的错误:错误TS1086:无法在环境上下文中声明访问器。n节点\\模块/three/src/core/InterleavedBufferAttribute.d.ts(20,6) :错误TS1086:无法在环境上下文中声明访问器。n节点\\u模块/three/src/core/InterleavedBufferAttribute.d.ts(21,6):错误TS1086:无法在环境上下文中声明访问器。n我在Angular 7 6中导入后已发现这些线程出错n,但它们都不适用于我。n需要建立我的网站。如何避免这些错误以完成重复的构建github.com/mrdoob/three.js角度8+Three.js生成错误。Typescript版本3.5.3 14于2020年1月12日星期日凌晨1:58打开n<2020年1月12日巴黎星期日下午5:58关闭n<2020年1月12日洛杉矶星期日下午6:58n<2020年1月13日星期一上午9:58关闭,2020年1月13日巴黎星期一下午1:07,2020年1月13日洛杉矶星期一下午2:07,2020年1月13日洛杉矶星期一下午2:07ambient context.21 set needsUpdate(value:boolean);~~~~~~~~~~~~~~~node_modules/three/src/core/InterleavedBufferAttribute.d.ts:20:6-…n帮助(请使用论坛)n如github所述,您必须使用3.7.*版本的Typescript来避免此问题。如果由于Angular需要较低版本而无法升级,则还必须使用较低版本的three.js。n我已将Angular更新为其最新版本8.2.14,但在3.6之前,我只能使用打字脚本。现在我降级到THREEjs r110,这很糟糕,因为我在做vr,最近有很多变化n Typescript Error after updating r112n

three.js更新r112后出现Typescript错误 为WP2原创文章,链接:https://www.wp2.cn/three-js/three-js%e6%9b%b4%e6%96%b0r112%e5%90%8e%e5%87%ba%e7%8e%b0typescript%e9%94%99%e8%af%af/