1. 首页
  2. WordPress 函数手册

require_if_theme_supports()

require_if_theme_supports( string $feature, string $include )

在加载实现主题的函数之前,检查主题对给定功能的支持。
Checks a theme’s support for a given feature before loading the functions which implement it.

目录锚点:#参数#返回#源码


参数(Parameters)

参数 类型 必填 说明
$feature (string) 必需 正在检查的功能。
$include (string) 必需 文件的路径。

返回(Return)

(bool)如果当前主题支持提供的功能,则为True,否则为false。


源码(Source)

/**
 * Checks a theme's support for a given feature before loading the functions which implement it.
 *
 * @since 2.9.0
 *
 * @param string $feature The feature being checked.
 * @param string $include Path to the file.
 * @return bool True if the current theme supports the supplied feature, false otherwise.
 */
function require_if_theme_supports( $feature, $include ) {
	if ( current_theme_supports( $feature ) ) {
		require ( $include );
		return true;
	}
	return false;
}
更新版本 源码位置 使用 被使用
2.9.0 wp-includes/theme.php:2899 0 1 function

require_if_theme_supports() 为WP2原创文章,链接:https://www.wp2.cn/functions/require_if_theme_supports/

发表评论

您的电子邮箱地址不会被公开。